Перейти к содержимому

Неправильный компилятор

Если при помощи gcc вы пытаетесь собрать какой-либо проект под Solaris 10 SPARC и на заведомо собирающемся проекте (например, под Solaris 10 x86) и при этом получаете собщение об ошибке наподобии этого:

In file included from /usr/include/sys/signal.h:34,
from /usr/include/signal.h:26,
from indexer.c:68:
/usr/include/sys/siginfo.h:259: error: parse error before "ctid_t"
/usr/include/sys/siginfo.h:292: error: parse error before '}' token
/usr/include/sys/siginfo.h:294: error: parse error before '}' token
/usr/include/sys/siginfo.h:390: error: parse error before "ctid_t"
/usr/include/sys/siginfo.h:392: error: conflicting types for `__proc'
/usr/include/sys/siginfo.h:261: error: previous declaration of `__proc'
/usr/include/sys/siginfo.h:398: error: conflicting types for `__fault'
/usr/include/sys/siginfo.h:267: error: previous declaration of `__fault'

То скорее всего у вас компилятор gcc установлен от другой версии Solaris (например, от Solaris 9).

2 thoughts on “Неправильный компилятор

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *